Apple Activation Server Outage
Incident Report for Phonecheck
Resolved
This issue should be resolved, devices are able to activate at this time, please try again at this time.
Posted Mar 03, 2022 - 12:44 PST
Investigating
We are currently investigating an issue with Apple's server directly which is affecting devices from being able to activate. This is NOT a Phonecheck related issue, it's an issue with Apple's activation server. This will be an issue even outside of Phonecheck and not something we can control. Please standby as we find out more. (The iOS Phonecheck application is not affected)
Posted Mar 03, 2022 - 12:01 PST
This incident affected: Products & Services (Apple iOS App).