iOS App not opening
Incident Report for Phonecheck
Resolved
The iOS app should be opening now. This was an issue with Apple's servers - they have resolved outages at this time.
Posted Aug 16, 2023 - 23:13 PDT
Investigating
Apple Servers are currently experiencing issues that are affecting the ability to open the iOS App.
Posted Aug 16, 2023 - 18:30 PDT
This incident affected: Apple Products & Services (Apple iOS App).