Server Disruption

Incident Report for Phonecheck

Resolved

This incident has been resolved.
Posted Jan 31, 2025 - 08:30 PST

Monitoring

We are receiving reports that Phonecheck is operational at this time
Posted Jan 31, 2025 - 08:27 PST

Investigating

We are currently receiving reports of users unable to sign in or process devices.
Posted Jan 31, 2025 - 08:20 PST
This incident affected: Phonecheck Desktop Products (Mac Desktop, Windows Desktop).