Phonecheck Service Outage

Incident Report for Phonecheck

Resolved

All services have been stable for the last 3 hours, considered resolved.
Posted Sep 01, 2026 - 11:05 PDT

Monitoring

We are monitoring all services to ensure they are stable
Posted Sep 01, 2026 - 08:10 PDT

Identified

The issue has been identified and it has been resolved, Phonecheck should be operational at this time.
Posted Sep 01, 2026 - 08:02 PDT

Investigating

We are currently investigating an issue with Phonecheck
Posted Sep 01, 2026 - 07:32 PDT
This incident affected: Phonecheck Desktop Products (Mac Desktop, Windows Desktop).