iOS App not opening
Incident Report for Phonecheck
Resolved
We're writing to let you know that the issue with our Phonecheck application has been resolved. A server issue on the Apple App Store affected the application's functionality.
Posted Feb 14, 2024 - 08:26 PST
Monitoring
We are starting to get reports of the server being fixed. Please restart the Phonecheck desktop application and install the Phonecheck mobile app onto iOS devices once more; it should allow the app to open.
Posted Feb 14, 2024 - 08:20 PST
Investigating
We are currently looking into the iOS app not opening, as it may be related to an Apple Server issue.
Posted Feb 14, 2024 - 08:02 PST
This incident affected: Apple Products & Services (Apple iOS App).