Users are receiving "Device License Expired" message
Incident Report for Phonecheck
Resolved
This is resolved, please restart Phonecheck if needed
Posted Jun 07, 2023 - 14:25 PDT
Identified
We are aware of the issue and are working on resolving it.
Posted Jun 07, 2023 - 13:09 PDT
This incident affected: Apple Products & Services (Apple iOS App) and Android Products & Services (Android App).