Apple Server

Incident Report for Phonecheck

Resolved

The iOS app is fully operational
Posted Apr 15, 2025 - 14:43 PDT

Monitoring

Apple has resolved the issue on their end; we are getting reports of users able to open the iOS app once again. Please restart Phonecheck and try again.
Posted Apr 15, 2025 - 14:26 PDT

Investigating

Apple is currently experiencing an issue on its end, which is preventing Phonecheck from accessing the mobile application for iOS. Please note that Androids can be processed at this time, while we wait to hear back from Apple.
Posted Apr 15, 2025 - 12:02 PDT
This incident affected: Apple Products & Services (Apple iOS App).