Server Outage
Incident Report for Phonecheck
Resolved
We appreciate your patience the issue is resolved.
Posted Sep 26, 2024 - 10:07 PDT
Monitoring
The issue is intermittent and we are monitoring the results.
Posted Sep 26, 2024 - 09:56 PDT
Investigating
We are currently investigating a server outage that is affecting the Phonecheck desktop application
Posted Sep 26, 2024 - 09:18 PDT
This incident affected: Phonecheck Desktop Products (Mac Desktop, Windows Desktop).