Issues logging in to Phonecheck desktop or opening the mobile application

Incident Report for Phonecheck

Resolved

The issue should be resolved at this time
Posted Jul 20, 2025 - 10:00 PDT

Investigating

Our development team is working to resolve an issue affecting the cloud portal and mobile processing.
Posted Jul 20, 2025 - 07:00 PDT
This incident affected: Cloud Portal (Cloud Portal).