iOS App not opening
Incident Report for Phonecheck
Resolved
The iOS app should be opening now; this was an issue with Apple's servers - they have resolved outages at this time.
Posted Jun 27, 2023 - 14:16 PDT
Investigating
We are currently investigating reports of the iOS app not opening
Posted Jun 27, 2023 - 13:07 PDT
This incident affected: Apple Products & Services (Apple iOS App).