Server Outage
Incident Report for Phonecheck
Resolved
This incident was resolved at 8:49 AM PST
Posted Sep 11, 2024 - 09:00 PDT
Investigating
We are currently investigating an outage that is causing issues with device processing on Phonecheck
Posted Sep 11, 2024 - 07:24 PDT
This incident affected: Phonecheck Desktop Products (Mac Desktop, Windows Desktop).