SimLock and CarrierLock API intermittent outages

Incident Report for Phonecheck

Resolved

This incident has been resolved; the SIM lock and carrier lock servers should be working normally again.
Posted Jul 29, 2026 - 12:13 PDT

Identified

Please note that APIs for CarrierLock and SimLock are experiencing intermittent issues on Desktop and are completely unable to be used on Single/Bulk IMEI checker.
Posted Jul 21, 2026 - 13:45 PDT
This incident affected: Apple Products & Services (Apple Simlock IMEI Service, Apple Carrierlock IMEI Service).