Apple Server Issue

Incident Report for Phonecheck

Resolved

Good News -- We’re starting to receive reports that the iOS app is operational again.
Please restart Phonecheck, select "Clear Cache" from the options at login, and then try processing your iOS devices.
Let us know if everything is working on your end.
Posted Aug 14, 2025 - 10:56 PDT

Identified

We’re aware that the Phonecheck iOS app is currently not opening. This issue is not on our side — it’s being caused by a problem with Apple’s servers. Apple Business Manager experienced outages yesterday and today, which has created a backlog of requests in their API. Unfortunately, this backlog is affecting the ability for our iOS app to launch properly.

We’re closely monitoring Apple’s status and expect the issue to resolve once their systems finish processing the queued requests.
Posted Aug 13, 2025 - 15:07 PDT

Investigating

We are currently investigating an issue that is stemming from Apple's Servers experiencing an outage.
Posted Aug 13, 2025 - 13:41 PDT
This incident affected: Apple Products & Services (Apple iOS App).