Cloud Portal outage affecting Desktop
Incident Report for Phonecheck
Resolved
This incident has been resolved.
Posted Mar 04, 2024 - 12:48 PST
Monitoring
We are getting reports of the issue being resolved, please restart Phonecheck.
Posted Feb 29, 2024 - 09:24 PST
Investigating
We are currently experiencing an outage
Posted Feb 29, 2024 - 08:54 PST
This incident affected: Apple Products & Services (Apple iOS App), Android Products & Services (Android App), and Cloud Products & Services (Cloud Portal).