Apple Server Issue

Incident Report for Phonecheck

Resolved

Apple resolved their server issue - https://www.apple.com/support/systemstatus/
Posted Feb 26, 2025 - 18:03 PST

Investigating

Our iOS app is currently being affected by Apple's current server issue, we are waiting on Apple to fix the issue.
Posted Feb 26, 2025 - 14:52 PST
This incident affected: Apple Products & Services (Apple iOS App).