Server Outage

Incident Report for Phonecheck

Resolved

This incident has been resolved.
Posted May 29, 2025 - 05:55 PDT

Investigating

We are currently investigating an outage that is causing issues with device processing on Phonecheck.
Posted May 29, 2025 - 05:20 PDT
This incident affected: Cloud Portal (Cloud Portal) and Phonecheck Desktop Products (Mac Desktop, Windows Desktop).