Issues logging in to Phonecheck desktop or opening the mobile application

Incident Report for Phonecheck

Resolved

Issue has been confirmed to be resolved
Posted Jul 15, 2025 - 14:05 PDT

Monitoring

The issue should be resolved. Please restart Phonecheck if needed.
Posted Jul 15, 2025 - 13:52 PDT

Investigating

We are currently investigating the issue
Posted Jul 15, 2025 - 13:05 PDT
This incident affected: Apple Products & Services (Apple iOS App) and Phonecheck Desktop Products (Mac Desktop, Windows Desktop).