Verizon Finance server degraded performance

Incident Report for Phonecheck

Resolved

Verizon server is back online
Posted Sep 28, 2023 - 13:23 PDT

Monitoring

The Verizon server should be back online, we are monitoring the status of the server at this time.
Posted Sep 28, 2023 - 07:27 PDT

Investigating

We are currently investigating this issue.
Posted Sep 26, 2023 - 06:51 PDT
This incident affected: Carrier Eligibility Services (Verizon Status).