Email Services
Incident Report for Phonecheck
Resolved
This incident has been resolved.
Posted Mar 30, 2022 - 08:35 PDT
Update
We are continuing to work on a fix for this issue. Services should be restored in 24 hours.
Posted Mar 29, 2022 - 08:19 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 29, 2022 - 08:15 PDT
This incident affected: Products & Services (Email Services).